Scheduled maintenance — Database cluster upgrades

Scheduled for May 17, 06:00 - 08:00 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted Apr 28, 2026 - 18:18 UTC

Scheduled

Status: Scheduled

Window:
Saturday, May 16, 2026 — 2:00 AM to 4:00 AM EST
Sunday, May 17, 2026 — 2:00 AM to 4:00 AM EST

Impact: A few minutes of downtime expected during each window as the database cluster restarts. The platform will be fully available outside of these short restart windows.

What we're doing: Upgrading our database clusters to improve performance, reliability, and security. No customer action is required.

If anything comes up, we'll let you know here — otherwise, operations will resume as expected outside the window. Thanks for your patience!
Posted Apr 28, 2026 - 15:21 UTC
This scheduled maintenance affects: Prism API and Prism Insights Engine.